node.js v0.5.4にはexpressがインストールできなかった。

node.js(v0.5.4)インストールメモ(amazon Linux)の続き

npmは無事インストールできましたが、expressのインストールに失敗しました。

[root@ip-10-146-158-41 ~]# curl http://npmjs.org/install.sh | sh
[root@ip-10-146-158-41 ~]# npm install express
npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: express@2.4.4
npm ERR! Required: {"node":">= 0.4.1 < 0.5.0"}
npm ERR! Actual:   {"npm":"1.0.25","node":"v0.5.4"}
npm ERR!
npm ERR! System Linux 2.6.35.11-83.9.amzn1.x86_64
npm ERR! command "node" "/usr/local/bin/npm" "install" "express"
npm ERR! cwd /root
npm ERR! node -v v0.5.4
npm ERR! npm -v 1.0.25
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     /root/npm-debug.log
npm not ok

Required: {"node":">= 0.4.1 < 0.5.0"}ということで、利用する場合、v0.4.10を利用したほうが良いみたい、